Volkswagen RNS 510 coding when installing with a factory amplifier

When retrofitting a RNS 510 into a vehicle with a factory amplifier coding is required to drop the “output stage power 26 dB” to “output stage line-out 12 dB”.  Poor sound quality and other problems will occur if this coding is not performed, the easiest way to see that the coding has not been performed correctly is that the fader option does not work for front/rear operation.

To make the chances you will need a dealer tool or Vagcom/VCDS. This guide covers the use of Vagcom/VCDS.

Open controller 37 – navigation and click on coding – 07

volkswagen_vcds_controller_37

Click Long Coding Helper

volkswagen_vcds_controller_37_long_coding_helper

Byte 1 select Bit 01 – Volkswagen Sound System.

This is the standard amplifier used in many Volkswagen cars, this changes the outputs from High to Low.

volkswagen_vcds_controller_37_long_coding_byte_1_sound_system

Byte 2 select Bit 00 – Sound System (active Speakers)

volkswagen_vcds_controller_37_long_coding_byte_2_sound_system

Byte 4 select Bit 01 – Speaker Monitoring Inactive (Sound System)

This turns off the speaker monitoring, the amplifier which is driving the speakers is performing this task and will report any problems with the speakers. If there is no amplifier the headunit does this checking.

volkswagen_vcds_controller_37_long_coding_byte_4_speaker_monitoring

Byte 5 select Bit 00 – Equalization: Linear

volkswagen_vcds_controller_37_long_coding_byte_5_equalization

Exit the long coding helper and save the changes. The RNS 510 doesn’t require a reboot and should start sounding better.

Another change that can be beneficial is changing the loudness, this can be performed by entering the test mode.

Accessing the Setup Menu on RNS 510 head units with firmware version 2660 / 2662 / 2664 / 2666 / 2668

Accessing the Setup Menu on RNS 510 head units with earlier firmware versions

31 comments to Volkswagen RNS 510 coding when installing with a factory amplifier

  • RNS coding problems

    Hello All,

    I just bought a RNS 510 for my passat 2008. The unit was installed and everything works great whitout the right steering wheel and no informations about media are available on the re dot screen. Does anyone knows how to cede the RNS 510?

    thx,
    marius

  • Morgan

    Hi! You need to enter 37 Navigation and enter the long coding and tick off the box with CAN-BAP Protocol! That should do the trick:-)

  • [...] hat keinen Vorverstärkerausgang. In Verbindung mit Dynaudio/VW-Sound ist der Ausgangspegel laut hier von “output stage power 26 dB” auf “output stage line-out 12 dB” heruntergeschraubt, ich [...]

  • billman

    Good evening. I did all the above steps and my rns-510 with the following specs 1T0 035 680 C SW:2680 V6 MAP and production date 05.01.2010 worked fine. My car is an MK2 Seat Leon 1.8 tsi facelift 2/2010. The only problem is that the gps can’t lock not even one satellite. Does anyone know what seems to be the problem? Is there something that I should do by using vcds or does my rns have a problem?

  • José Mendes

    Hello!! I have a VW EOS with the 10 satellites Dynaudio audio system. Which bytes option should I choose when configuring? ANYONE CAN HELP PLEASE? Thanks!

  • [...] may have the dynaudio package, so if this is the case you need to do this Volkswagen RNS 510 coding when installing with a factory amplifier | my-gti.com Reply With Quote   + Reply to Thread « Previous Thread | [...]

  • [...] Hi All I have a vag com cable but need some advice on coding the unit can anyone help? Cheers Volkswagen RNS 510 coding when installing with a factory amplifier Entering setup on the RNS 510 with recent firmware Changing the Region Code on the Volkswagen RNS [...]

  • Maria

    Have retrofitted the RNS 510 form a ’07 Touareg to a ’05 one and running FW1100 with SW V6.1. All is working OK except I have no verbal instruction from the unit while travelling. At the off she speaks saying the route is being calculated and then she says the route is in the highlighted direction. At the end of the journey she says you have reached your destination. In between nothing and the moving arrow is always in the correct position. Is this a coding problem or has anyone come across it before ? Thanks

  • Aristide

    How do I tell what amplifier I have?

    My car is a 2011 Jetta Sportwagen TDI. I haven’t changed the amplifier, but I don’t know if it came with the premium sound or not (which would mean it’s the dynaudio one, correct?) I coded it to 01 – Volkswagen, but I *think* there may be something wrong with the sound.

    Is there a specific kind of sound I could play from, the stereo to determine if I’ve got this setting wrong?

    Thanks,
    Aristide

  • [...] have been able to load the site and I have some more questions: Volkswagen RNS 510 coding when installing with a factory amplifier | my-gti.com What does this mean with a "When retrofitting a RNS 510 into a vehicle with a factory [...]

  • Alex Seleznev

    Can I do the same trick with my RCD-310 to convert power-outs into line-outs?

    Alex, Russia.

  • Dre

    Hello,
    I retrofixed Dynaudio with my RNS510 in my Passat 3C MY 2006. Now when i turn the key to off, but leave it into the slot, the sound turn off after about 10 to 15 seconds. Anyone a sugestion what to do?

    Kind regards,
    Andre (Belgium)

  • ucs

    Hi i have a mk edition 30 iv put a bury nokia 6700 cradle and programmed in on the vcds system but it showing live shorted out on supply to cradle (factory fitted system with the nokia bluetooth unit under driver seat)

  • Daz

    I have just replaced my RCD 510 unit with an RNS 510 on my Mk6 Golf. On the startup screen it says ‘powered by Dynaudio’. Problem is my vehicle is not equipped with Dynaudio. I have also noticed sound quality is not as good as with the original RCD unit so wondered if the two were connected in some way. Is there a setting that requires changing via VCDS to disable the unit from thinking it Is connected to a Dynaudio system?
    Thanks

  • [...] get enough volume. help will be greatly appreciated. Did you choose no soundsystem installed? Volkswagen RNS 510 coding when installing with a factory amplifier | my-gti.com Basically the opposite of what I've done above. Byte01 – 00 no sound system Byte02 – 04 4 [...]

  • [...] Sat Nav System. 2. DIY – RNS510 install for MKVI (w/bluetooth and MDI) 3. DIY – RNS510 Install 4. Volkswagen RNS 510 coding when installing with a factory amplifier | my-gti.com The physical installation is just as easy as everyone says, it really is just plug and play. All I [...]

  • ben

    Taking my car to dealer tommorow to have them recode my radio. I have an aftermarket amp but what is the difference in output between choosing volkswagen sound system and dyn audio? The other DSP options I assume are for if you have a DSP unit?

    What does the active speakers setting vs 4 speakers setting do?

    What is speaker monitoring?

  • Pasha

    Guys,

    I have finished the installation of Dynaudio amp and speakers into my Passat CC 2011 and now I’m a bit confused with proper RNS coding. In particular, I wonder what is the difference between those two bits in byte 1 “05 Dynaudio Sound System” vs “07 Dynaudio Sound System (BAP DSP)”.

    Thanks in advance, I will really appreciate your feedback.

  • GolfV

    i have RNS 510 just working fine, only my back doors speakers are not work,
    can i use the same coding to enable this?

  • Carl

    I have the factory RNS 510 in my Golf R , I decided to upgrade the amp and add a sub along with the audison Bit one Processor.. It sound’s awesome but the problem is the volume can not be contoled from the steering wheel or the head unit.Just through the bit one. Has anyone else had this problem ? Or has anyone changed the factory amp and re code the unit to work ?

    VW had it for 3 full days and could’nt do it ..

    Thanks

    Carl

  • Rudy

    Carl,
    I will be doing the exact same thing (in passat CC)
    Factory RNS 510 + mult funct R line steering wheel.
    Bit Ten + 5 channel Helix amplifier, with stock speakers and JL audio 12 inch sub in spare wheel space.
    I would advice you to take some resistors, could try something like 16 ohms, and connect them on the output of the rns, so you get a real resistance again on the output, which should make it all work again.
    If not, you can go to 8ohm resistors. But ofcourse, they should be 20watt versions, and it is not the most ideal solution, but should help for the time being.
    ps, can you reconnect like it was before? then it should all work again.

    Good luck

  • [...] change the coding. You may need to set the coding up. Trial and error maybe. Try this for starters: Volkswagen RNS 510 coding when installing with a factory amplifier | my-gti.com Current: 2011 Skoda Octavia vRS TDI DSG wagon|Race Blue|Leather|Dynamic Xenons|Fiberdyne [...]

  • stuart metcalfe

    Hi
    I have retro fitted a rcd 500 to my 2005/2006 golf gti(replacing rcd300)
    but the 500 was fitted to car with a sound pack(amplifer)but my car doesn’t have one,so the 500 faders doesn’t work on the front speakers
    can i code the stereo (rcd500)so the fronts work??

  • Carl

    Im still having problems … It now sounds ok through the bit one but I still can’t get the head unit coded to a fixed line out ? ( like it was originally but I couldn’t use the steering controls )

  • Peter papas

    I swapped my RNS 315 for an RNS 501 in my GLi with the Febder Audio system and everything seems to be working except the volume. I havn’t coded it through vag-con and was wondering if anyone else had this issue??

  • Peter

    I ment an RNS 510 duh!!

  • [...] VCDS to change to the output to 'Volkswagen sound system' under address 37. Some screenshots here: Volkswagen RNS 510 coding when installing with a factory amplifier | my-gti.com Current: 2011 Skoda Octavia vRS TDI DSG wagon|Race Blue|Leather|Dynamic Xenons|730L BT|MDI|SSD [...]

  • Adi

    Hi I have RNS510 and reverse camera factory fitted to a 2008 Tiguan. The problem is the Camera and RNS does not always power up with the ignition? Dealer checked aand found low power on the ignition power output? problem is better but still exists. Also RNS does not always switch off with the removal of the key?? Help.

  • [...] below when the unit was installed but just wanted to troubleshoot the sound settings a bit more Volkswagen RNS 510 coding when installing with a factory amplifier | my-gti.com The guide said "the easiest way to see that the coding has not been performed correctly is [...]

  • [...] and check the coding for the RNS is correctly set. Maverick has a good writeup with screenshots here. Current: 2011 Skoda Octavia vRS TDI DSG wagon|Race Blue|Leather|Dynamic Xenons|730L BT|MDI|SSD [...]

  • [...] coding for my RCD 510 and it worked !! Original instruction is for RNS510.. Check this out: Volkswagen RNS 510 coding when installing with a factory amplifier | my-gti.com Reply With [...]

Leave a Reply